App Version Compare

Publish to pub-web.flutter-io.cn codecov Tests

Overview

This Dart package provides a utility for parsing version strings according to Semantic Versioning (SemVer) and comparing two versions. It's particularly useful for managing app versions and implementing version comparison logic, such as determining whether a force update is required based on a version retrieved from a remote configuration.

Installation

You can install this package via pub-web.flutter-io.cn. Add the following line to your pubspec.yaml file:

Then, run:

flutter pub add app_version_compare

Usage

Comparing Versions

void main() {
  final remoteConfigVersion = '1.2.4';
  final appVersion = '1.2.3';

  final remoteVersion = AppVersion.fromString(remoteConfigVersion);
  final appCurrentVersion = AppVersion.fromString(appVersion);

  if (appCurrentVersion >= remoteVersion) {
    print('The app is updated!');
    print('Current app version: $appCurrentVersion');
    print('Latest version available: $remoteVersion');
  } else {
    print('The app is out of date!');
    print('Current app version: $appCurrentVersion');
    print('Latest version available: $remoteVersion');
  }
}

Support

For any issues or suggestions, please open an issue on GitHub.

License

This package is licensed under the MIT License. See the LICENSE file for details.