ametory_framework 0.0.91 copy "ametory_framework: ^0.0.91" to clipboard
ametory_framework: ^0.0.91 copied to clipboard

Ametory Flutter Framework help you build powerfull flutter pattern.

4
likes
90/ 140
pub points
0%
popularity

We analyzed this package 4 hours ago, and awarded it 90 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://ametory.id was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 63 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: ametory_framework, api_client, api_client.ApiClient, api_client.ApiClient.ApiClient, api_client.ApiClient.bearerToken.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

WARNING: Unused import: 'dart:developer'.

bin/admin.dart:4:8

  ╷
4 │ import 'dart:developer';
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze bin/admin.dart

WARNING: Unused import: 'package:json2yaml/json2yaml.dart'.

bin/doc.dart:4:8

  ╷
4 │ import 'package:json2yaml/json2yaml.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze bin/doc.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ametory_ui ^0.0.73 0.0.73 0.0.73
cosmic_frontmatter ^1.0.2 1.0.3 1.0.3
dio ^5.1.2 5.4.3+1 5.4.3+1
email_validator ^2.1.17 2.1.17 2.1.17
flutter flutter 0.0.0 0.0.0
flutter_markdown ^0.6.10+5 0.6.23 0.7.1
freezed_annotation ^2.4.1 2.4.1 2.4.1
json2yaml ^3.0.0 3.0.1 3.0.1
markdown ^7.1.0 7.2.2 7.2.2
owesome_validator ^0.0.6 0.0.6 0.0.6
path ^1.8.3 1.9.0 1.9.0
path_provider ^2.0.11 2.1.3 2.1.3
recase ^4.0.0 4.1.0 4.1.0
visibility_detector ^0.4.0+2 0.4.0+2 0.4.0+2
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.34 1.3.34
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore - 4.17.4 4.17.4
cloud_firestore_platform_interface - 6.2.4 6.2.4
cloud_firestore_web - 3.12.4 3.12.4
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
crypto - 3.0.3 3.0.3
csslib - 0.17.3 1.0.0
fake_async - 1.3.1 1.3.1
faker - 2.1.0 2.1.0
ffi - 2.1.2 2.1.2
file_picker - 5.5.0 8.0.3
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.4 0.9.4
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
firebase_auth - 4.19.6 4.19.6
firebase_auth_platform_interface - 7.2.7 7.2.7
firebase_auth_web - 5.11.6 5.11.6
firebase_core - 2.31.1 2.31.1
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.17.0 2.17.0
firebase_storage - 11.7.6 11.7.6
firebase_storage_platform_interface - 5.1.21 5.1.21
firebase_storage_web - 3.9.6 3.9.6
fixnum - 1.1.0 1.1.0
flex_color_picker - 3.5.0 3.5.0
flex_seed_scheme - 2.0.0 2.0.0
fluentui_icons - 1.0.0 1.0.0
flutter_html - 3.0.0-beta.2 3.0.0-beta.2
flutter_inappwebview - 5.8.0 6.0.0
flutter_keyboard_visibility - 5.4.1 6.0.0
flutter_keyboard_visibility_linux - 1.0.0 1.0.0
flutter_keyboard_visibility_macos - 1.0.0 1.0.0
flutter_keyboard_visibility_platform_interface - 2.0.0 2.0.0
flutter_keyboard_visibility_web - 2.0.0 2.0.0
flutter_keyboard_visibility_windows - 1.0.0 1.0.0
flutter_parsed_text - 2.2.1 2.2.1
flutter_plugin_android_lifecycle - 2.0.19 2.0.19
flutter_rating_bar - 4.0.1 4.0.1
flutter_social_textfield - 0.1.2 0.1.2
flutter_svg - 2.0.10+1 2.0.10+1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
google_fonts - 6.2.1 6.2.1
google_identity_services_web - 0.3.1+1 0.3.1+1
google_sign_in - 6.2.1 6.2.1
google_sign_in_android - 6.1.23 6.1.23
google_sign_in_ios - 5.7.6 5.7.6
google_sign_in_platform_interface - 2.4.5 2.4.5
google_sign_in_web - 0.12.4 0.12.4
html - 0.15.4 0.15.4
html2md - 1.3.1 1.3.1
html_editor_enhanced_forked_by_ametory - 2.5.2 2.5.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
image_picker - 1.1.1 1.1.1
image_picker_android - 0.8.12+1 0.8.12+1
image_picker_for_web - 3.0.4 3.0.4
image_picker_ios - 0.8.11+2 0.8.11+2
image_picker_linux - 0.2.1+1 0.2.1+1
image_picker_macos - 0.2.1+1 0.2.1+1
image_picker_platform_interface - 2.10.0 2.10.0
image_picker_windows - 0.2.1+1 0.2.1+1
infinite_listview - 1.1.0 1.1.0
intl - 0.19.0 0.19.0
json_annotation - 4.9.0 4.9.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
list_counter - 1.0.2 1.0.2
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
material_tag_editor - 0.1.2 0.1.2
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
numberpicker - 2.1.2 2.1.2
path_parsing - 1.0.1 1.0.1
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
pedantic - 1.11.1 1.11.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointer_interceptor - 0.10.1+1 0.10.1+1
pointer_interceptor_ios - 0.10.0+2 0.10.0+2
pointer_interceptor_platform_interface - 0.10.0+1 0.10.0+1
pointer_interceptor_web - 0.10.2 0.10.2
scroll_to_index - 3.0.1 3.0.1
seo_renderer - 0.6.0 0.6.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
swipe_to - 1.0.6 1.0.6
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
typed_data - 1.3.2 1.3.2
url_launcher - 6.2.6 6.2.6
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
video_player - 2.8.6 2.8.6
video_player_android - 2.4.14 2.4.14
video_player_avfoundation - 2.6.1 2.6.1
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.0 2.3.0
vm_service - 14.2.1 14.2.2
web - 0.5.1 0.5.1
webview_flutter - 4.7.0 4.7.0
webview_flutter_android - 3.16.1 3.16.1
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.13.1 3.13.1
webviewx_plus - 0.4.1 0.5.0
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.10+5` on flutter_markdown does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions flutter_markdown to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.