amplify_auth_repository 0.0.1 copy "amplify_auth_repository: ^0.0.1" to clipboard
amplify_auth_repository: ^0.0.1 copied to clipboard

Dart package which manages the authentication domain with aws amplify.

AWS Amplify Auth Cognito / S3 Storage Repository #

Flutter package to implement authentication and storage using AWS Amplify.

Features ✨ #

  • Sign up with email and password
  • Sign in with email and password
  • Maintain Session
  • Send/Resend Verification code
  • Reset Password
  • Set/Get Attributes
  • Upload file on S3 bucket
  • Generate URL for the uploaded file

Getting Started 🎉 #

Amplify 📝 #

  1. Create your project
  2. Download amplifyconfiguration.dart file
  3. Docs https://docs.amplify.aws/start/getting-started/installation/q/integration/flutter/

Run the project 🚀 #

  1. flutter run
0
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Dart package which manages the authentication domain with aws amplify.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

amplify_auth_cognito, amplify_flutter, amplify_storage_s3, equatable, flutter

More

Packages that depend on amplify_auth_repository