api_call_manager 0.0.6 copy "api_call_manager: ^0.0.6" to clipboard
api_call_manager: ^0.0.6 copied to clipboard

Simple package that allow you to call APIs

TODO: Api Manager package allows us to call api simple

Usage #

you need to call this function like :

 Future<void> getPost() async {
    final data = await ApiManager()
        .getData(apiUrl: "https://example.com");
    setState(() => _post = data);
  } 

Aditional Information #

This package depends on flutter_easyloading : so you need to do this in material app in main.dart.

 MaterialApp(
      builder: EasyLoading.init(),
      debugShowCheckedModeBanner: false,
      
    );
    ```

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

Simple package that allow you to call APIs

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_easyloading, http

More

Packages that depend on api_call_manager