appwrite_dart_wrapper 0.6.1 copy "appwrite_dart_wrapper: ^0.6.1" to clipboard
appwrite_dart_wrapper: ^0.6.1 copied to clipboard

Function Wrapper for dart_appwrite, with error handling and dependency injection.

1
likes
120/ 140
pub points
0%
popularity

We analyzed this package 33 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

8 out of 33 API elements (24.2 %) have documentation comments.

Some symbols that are missing documentation: appwrite_dart_wrapper, appwrite_dart_wrapper.BizFun, appwrite_dart_wrapper.FnOptExecution, appwrite_dart_wrapper.FnOptRecord, appwrite_dart_wrapper.Req.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:appwrite_dart_wrapper/appwrite_dart_wrapper.dart that imports:
  • package:appwrite_dart_wrapper/src/start_wrapper.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/start_wrapper.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/test_wrapper.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dart_appwrite ^8.0.0 8.0.1 11.0.2
get_it ^7.6.0 7.7.0 7.7.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http - 1.0.0 1.2.1
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^8.0.0` on dart_appwrite does not support the stable version `9.0.1`.

Try running dart pub upgrade --major-versions dart_appwrite to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

1
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Function Wrapper for dart_appwrite, with error handling and dependency injection.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

dart_appwrite, get_it

More

Packages that depend on appwrite_dart_wrapper