ast_explorer_cli 0.2.0 copy "ast_explorer_cli: ^0.2.0" to clipboard
ast_explorer_cli: ^0.2.0 copied to clipboard

A Command-Line Interface for explorer flutter/dart simplified ast.

1
likes
130/ 140
pub points
0%
popularity

We analyzed this package 4 hours ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/lsaudon/ast_explorer_cli/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux
  • ✓ macOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.13.0 5.13.0 6.5.1
args ^2.4.1 2.5.0 2.5.0
cli_completion ^0.3.0 0.3.0 0.5.0
collection ^1.17.2 1.18.0 1.18.0
equatable ^2.0.5 2.0.5 2.0.5
file ^6.1.4 6.1.4 7.0.0
mason_logger ^0.2.6 0.2.15 0.2.15
path ^1.8.3 1.9.0 1.9.0
pub_updater ^0.3.0 0.3.1 0.4.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 69.0.0
async - 2.11.0 2.11.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
platform - 3.1.4 3.1.4
process - 4.2.4 5.0.2
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^5.13.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.3.0` on cli_completion does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_completion to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.