awesome_drawer_bar 1.2.0 copy "awesome_drawer_bar: ^1.2.0" to clipboard
awesome_drawer_bar: ^1.2.0 copied to clipboard

A Flutter package with custom implementation of the Side Menu (Drawer)

40
likes
120/ 140
pub points
91%
popularity

We analyzed this package 32 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

26 out of 40 API elements (65.0 %) have documentation comments.

Some symbols that are missing documentation: adaptive_layout_custom, adaptive_layout_custom.AdaptiveLayoutCustom, adaptive_layout_custom.AdaptiveLayoutCustom.AdaptiveLayoutCustom, awesome_drawer_bar, awesome_drawer_bar.AwesomeDrawerBar.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/awesome_drawer_bar.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/widgets/adaptive_layout_custom.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_adaptive_scaffold ^0.0.8 0.0.9 0.1.10+1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.8` on flutter_adaptive_scaffold does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions flutter_adaptive_scaffold to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

40
likes
120
pub points
91%
popularity

Publisher

verified publisherappcheap.io

A Flutter package with custom implementation of the Side Menu (Drawer)

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_adaptive_scaffold

More

Packages that depend on awesome_drawer_bar