bridgefy 1.1.5 copy "bridgefy: ^1.1.5" to clipboard
bridgefy: ^1.1.5 copied to clipboard

The Bridgefy SDK is a state-of-the-art, plug-and-play package that lets people use apps when they don’t have access to the Internet by using mesh networ

12
likes
120/ 140
pub points
56%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://bridgefy.me/sdk was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/bridgefy/bridgefy_flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

35 out of 76 API elements (46.1 %) have documentation comments.

Some symbols that are missing documentation: bridgefy, bridgefy.Bridgefy.currentUserID, bridgefy.Bridgefy.isInitialized, bridgefy.Bridgefy.isStarted, bridgefy.BridgefyError.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:bridgefy/bridgefy.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:bridgefy/bridgefy.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:bridgefy/bridgefy.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:bridgefy/bridgefy.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/bridgefy_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

12
likes
120
pub points
56%
popularity

Publisher

verified publisherbridgefy.me

The Bridgefy SDK is a state-of-the-art, plug-and-play package that lets people use apps when they don’t have access to the Internet by using mesh networ

Homepage
Repository (GitHub)
View/report issues

Topics

#network #offline #mesh #ble #bluetooth

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on bridgefy