category_navigator 1.1.6 copy "category_navigator: ^1.1.6" to clipboard
category_navigator: ^1.1.6 copied to clipboard

A flutter ui package for cool navigation bar with a lot of customization options

16
likes
130/ 140
pub points
52%
popularity

We analyzed this package 7 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

20 out of 35 API elements (57.1 %) have documentation comments.

Some symbols that are missing documentation: category_navigator.CategoryNavigator, category_navigator.CategoryNavigator.CategoryNavigator, category_navigator.CategoryNavigator.borderRadius, category_navigator.CategoryNavigator.highlightBackgroundColor, category_navigator.CategoryNavigator.highlightTextStyle.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/category_navigator.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

16
likes
130
pub points
52%
popularity

Publisher

verified publisheranonymousaliens.app

A flutter ui package for cool navigation bar with a lot of customization options

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on category_navigator