curt 0.1.2 copy "curt: ^0.1.2" to clipboard
curt: ^0.1.2 copied to clipboard

Simple wrapper for curl in dart.

4
likes
120/ 140
pub points
25%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 26 API elements (3.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: curt.Curt, curt.Curt.Curt, curt.Curt.debug, curt.Curt.delete, curt.Curt.environment.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:curt/curt.dart that imports:
  • package:curt/src/curt_response.dart that imports:
  • package:curt/src/curt_http_headers.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
intl >=0.17.0 <1.0.0 0.19.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

4
likes
120
pub points
25%
popularity

Publisher

verified publisher3daysapp.com.br

Simple wrapper for curl in dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

intl

More

Packages that depend on curt