dart_dependency_checker 0.1.5 copy "dart_dependency_checker: ^0.1.5" to clipboard
dart_dependency_checker: ^0.1.5 copied to clipboard

A utility package for checking dependencies within Dart/Flutter packages.

3
likes
140/ 140
pub points
38%
popularity

We analyzed this package 23 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

31 out of 44 API elements (70.5 %) have documentation comments.

Some symbols that are missing documentation: dart_dependency_checker.DepsUnusedParams.devIgnores, dart_dependency_checker.DepsUnusedParams.fix, dart_dependency_checker.DepsUnusedParams.mainIgnores, dart_dependency_checker.DepsUnusedParams.path, dart_dependency_checker.DepsUnusedResults.devDependencies.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:dart_dependency_checker/dart_dependency_checker.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:dart_dependency_checker/dart_dependency_checker.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:dart_dependency_checker/dart_dependency_checker.dart that declares support for platforms: Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

3
likes
140
pub points
38%
popularity

Publisher

verified publisher0ohm.de

A utility package for checking dependencies within Dart/Flutter packages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, yaml

More

Packages that depend on dart_dependency_checker