dart_dependency_checker_cli 0.1.8 copy "dart_dependency_checker_cli: ^0.1.8" to clipboard
dart_dependency_checker_cli: ^0.1.8 copied to clipboard

A command-line utility for checking dependencies within Dart/Flutter packages.

dart_dependency_checker_cli #

A command-line wrapper using utilities from dart_dependency_checker for checking dependencies within Dart/Flutter packages.

Usage #

Install:

dart pub global activate dart_dependency_checker_cli

Run:

ddc deps-unused -p /some/package --dev-ignores lints,build_runner
ddc transitive-use -p /some/package --main-ignores async,meta

Or even:

# With instant fix
ddc deps-unused -p /some/package --fix

# In a wild mono repo environment
melos exec -c1 -- ddc deps-unused

# Run everywhere
for d in */ ; do (cd $d && ddc deps-unused); done;

Future roadmap #

  • Command dep-origin: Utilize dart pub deps -s compact --no-dev to extract the origin of a direct/transitive dependency.

License #

See the LICENSE file.

Version history #

See the CHANGELOG.md file.

1
likes
140
pub points
20%
popularity

Publisher

verified publisher0ohm.de

A command-line utility for checking dependencies within Dart/Flutter packages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

args, dart_dependency_checker, yaansi, yaml

More

Packages that depend on dart_dependency_checker_cli