dinamico_dart 0.0.3 copy "dinamico_dart: ^0.0.3" to clipboard
dinamico_dart: ^0.0.3 copied to clipboard

Library to support he Dinâmico Clojure library (https://github.com/pfeodrippe/dinamico)

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 33 hours ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 6 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: dinamico_dart, dinamico_dart.Dinamico, dinamico_dart.Dinamico.Dinamico, dinamico_dart.Dinamico.build, dinamico_dart.Dinamico.register.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dinamico_dart/dinamico_dart.dart that imports:
  • package:json_dynamic_widget_plugin_svg/json_dynamic_widget_plugin_svg.dart that imports:
  • package:json_dynamic_widget_plugin_svg/src/json_svg_plugin.dart that imports:
  • package:json_dynamic_widget/json_dynamic_widget.dart that imports:
  • package:json_dynamic_widget/src/builders/json_testable_builder.dart that imports:
  • package:automated_testing_framework/widgets.dart that imports:
  • package:automated_testing_framework/src/widgets/testable_text_form_field.dart that imports:
  • package:automated_testing_framework/automated_testing_framework.dart that imports:
  • package:automated_testing_framework/src/store/components/io_test_store.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'ToolbarOptions' is deprecated and shouldn't be used. Use `contextMenuBuilder` instead. This feature was deprecated after v3.3.0-0.5.pre.

lib/src/text_form_builder.dart:118:9

    ╷
118 │   final ToolbarOptions? toolbarOptions;
    │         ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/text_form_builder.dart

INFO: 'toolbarOptions' is deprecated and shouldn't be used. Use `contextMenuBuilder` instead. This feature was deprecated after v3.3.0-0.5.pre.

lib/src/text_form_builder.dart:493:9

    ╷
493 │         toolbarOptions: widget.builder.toolbarOptions,
    │         ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/text_form_builder.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
child_builder ^2.0.0+3 2.0.2 2.0.2
flutter flutter 0.0.0 0.0.0
form_validation ^2.1.0+2 2.1.0+24 3.1.1+5
http ^0.13.4 0.13.6 1.2.1
json_class ^2.1.2+4 2.1.2+14 3.0.0+13
json_dynamic_widget ^4.0.1+2 4.1.1+1 7.2.0
json_dynamic_widget_plugin_material_icons ^2.0.2 2.1.0 4.0.0+20
json_dynamic_widget_plugin_svg ^2.0.0+2 2.1.0 4.0.0+21
json_theme ^3.3.1 3.3.1 6.5.0+1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
async - 2.11.0 2.11.0
automated_testing_framework - 3.3.1+1 5.0.0+14
automated_testing_framework_models - 2.0.9+13 2.0.10+8
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
device_info_plus - 3.2.4 10.1.0
device_info_plus_linux - 2.1.1 5.0.0
device_info_plus_macos - 2.2.3 5.0.0
device_info_plus_platform_interface - 2.6.1 7.0.0
device_info_plus_web - 2.1.0 5.0.0
device_info_plus_windows - 2.1.1 6.0.0
encrypt - 5.0.3 5.0.3
fake_async - 1.3.1 1.3.1
ffi - 1.2.1 2.1.2
file - 6.1.4 7.0.0
flutter_markdown - 0.6.23 0.7.1
flutter_svg - 1.1.6 2.0.10+1
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
interpolation - 2.1.2 2.1.2
intl - 0.17.0 0.19.0
js - 0.7.1 0.7.1
json_conditional - 2.1.0+17 3.0.1+12
json_path - 0.4.4 0.7.1
json_schema2 - 2.0.2+18 5.1.3
logging - 1.2.0 1.2.0
markdown - 7.2.2 7.2.2
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
material_icons_named - 1.1.3 3.16.0+1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
package_info_plus - 1.4.2 8.0.0
package_info_plus_linux - 1.0.5 2.0.0
package_info_plus_macos - 1.3.0 2.0.0
package_info_plus_platform_interface - 1.0.2 3.0.0
package_info_plus_web - 1.0.6 2.0.0
package_info_plus_windows - 1.0.5 3.0.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
petitparser - 5.4.0 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.9.1 3.9.1
provider - 6.1.2 6.1.2
quiver - 3.2.1 3.2.1
rest_client - 2.2.0+4 2.4.0
rfc_6901 - 0.1.1 0.2.0
rxdart - 0.27.7 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
static_translations - 2.1.1+19 2.1.2+12
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
template_expressions - 1.1.7+10 3.2.0+7
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
websafe_svg - 2.1.3+1 3.0.1+1
win32 - 2.6.1 5.5.1
xml - 6.3.0 6.5.0
yaml - 3.1.2 3.1.2
yaon - 1.1.4+10 1.1.4+10

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^2.1.0+2` on form_validation does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions form_validation to update the constraint.

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.