dio_handler 0.0.2 copy "dio_handler: ^0.0.2" to clipboard
dio_handler: ^0.0.2 copied to clipboard

DioHandler provides utility functions and customization options to streamline API request handling in your Flutter applications.

13
likes
120/ 140
pub points
11%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 16 API elements (37.5 %) have documentation comments.

Some symbols that are missing documentation: dio_handler.DioHandler, dio_handler.DioHandler.DioHandler, dio_handler.DioHandler.callAPI, dio_handler.DioHandler.customErrorDialog, dio_handler.DioHandler.customLoadingDialog.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:dio_handler/dio_handler.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:dio_handler/dio_handler.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:dio_handler/dio_handler.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:dio_handler/dio_handler.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/custom_dialog.dart:1:1

  ╷
1 │ part of dio_handler;
  │ ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/custom_dialog.dart

INFO: The part-of directive uses a library name.

lib/src/network_call.dart:1:1

  ╷
1 │ part of dio_handler;
  │ ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/network_call.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity_plus ^5.0.1 5.0.2 6.0.3
dio ^5.3.3 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_plus_platform_interface - 1.2.4 2.0.0
dbus - 0.7.10 0.7.10
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nm - 0.5.0 0.5.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.0.1` on connectivity_plus does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions connectivity_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

13
likes
120
pub points
11%
popularity
screenshot

Publisher

verified publisherarfaz.tech

DioHandler provides utility functions and customization options to streamline API request handling in your Flutter applications.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#dio #api-call #dio-handler #http

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

connectivity_plus, dio, flutter

More

Packages that depend on dio_handler