efipay 1.0.6 copy "efipay: ^1.0.6" to clipboard
efipay: ^1.0.6 copied to clipboard

A dart library for integration with payment services provided by Efi.

3
likes
125/ 160
pub points
59%
popularity

We analyzed this package 20 hours ago, and awarded it 125 pub points (of a possible 160):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:9:29

  ╷
9 │ Para mais informações sobre <a href="http://sejaefi.com.br/api">parâmetros</a> e <a href="http://sejaefi.com.br/tarifas">valores/tarifas</a> consulte nosso site.</p>
  │                             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1 out of 4 API elements (25.0 %) have documentation comments.

Some symbols that are missing documentation: EfiPay, EfiPay.EfiPay.call, EfiPay.EfiPay.isMobileDevice.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:efipay/efipay.dart that imports:
  • package:efipay/src/efiPay.dart that imports:
  • package:efipay/src/end_points.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 19 issues. Showing the first 2:

WARNING: The value of the field '_pixCert' isn't used.

lib/src/auth.dart:15:10

   ╷
15 │   String _pixCert = '';
   │          ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/auth.dart

INFO: Statements in an if should be enclosed in a block.

lib/src/api_request.dart:29:9

   ╷
29 │         await this._auth?.authorize();
   │         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/api_request.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
encrypt ^5.0.0 5.0.3 5.0.3
flutter flutter 0.0.0 0.0.0
pointycastle ^3.2.0 3.9.1 3.9.1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.3 1.5.3
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
125
pub points
59%
popularity

Publisher

verified publisherefipay.com.br

A dart library for integration with payment services provided by Efi.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

encrypt, flutter, pointycastle

More

Packages that depend on efipay