fastnet 1.0.2 icon indicating copy to clipboard operation
fastnet: ^1.0.2 copied to clipboard

A Dart package that allows you to test your network download and upload speed using fast.com.

6
likes
40/ 140
pub points
0%
popularity

We analyzed this package 11 days ago, and awarded it 40 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resultion failed, unable to run dartdoc.

10/10 points: Package has an example

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 50icon to trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
icon indicating section status
Support up-to-date dependencies
0 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.0-166.0.dev. Cannot run `flutter pub outdated`.

pubspec.yaml:6:8

  ╷
6 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.0-166.0.dev.

pubspec.yaml:6:8

  ╷
6 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.2.1)

pubspec.yaml:6:8

  ╷
6 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.21.43, Flutter 3.16.1, Dart 3.2.1.

Check the analysis log for details.

6
likes
40
pub points
0%
popularity

Publisher

verified publisher icondammak.dev

A Dart package that allows you to test your network download and upload speed using fast.com.

Repository (GitHub)
View/report issues

License

Icon for licenses.MIT (LICENSE)

Dependencies

equatable, flutter, puppeteer

More

Packages that depend on fastnet