fhir_uscore 0.9.5 copy "fhir_uscore: ^0.9.5" to clipboard
fhir_uscore: ^0.9.5 copied to clipboard

FHIR library for using the USCore specifications, based on the full fhir package.

5
likes
130/ 140
pub points
37%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

479 out of 1265 API elements (37.9 %) have documentation comments.

Some symbols that are missing documentation: allergy_intolerance, allergy_intolerance.AllergyIntoleranceUsCore.contained, allergy_intolerance.AllergyIntoleranceUsCore.extension_, allergy_intolerance.AllergyIntoleranceUsCore.implicitRules, allergy_intolerance.AllergyIntoleranceUsCore.language.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fhir ^0.9.5 0.9.5 0.12.0
fhir_at_rest ^0.9.5 0.9.5 0.12.0
freezed_annotation ^2.2.0 2.4.1 2.4.1
http ^0.13.5 0.13.6 1.2.1
json_annotation ^4.8.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
xml - 6.5.0 6.5.0
xml2json - 5.3.6 6.2.3
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.9.5` on fhir does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions fhir to update the constraint.

The constraint `^0.9.5` on fhir_at_rest does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions fhir_at_rest to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

5
likes
130
pub points
37%
popularity

Publisher

verified publisherfhirfli.dev

FHIR library for using the USCore specifications, based on the full fhir package.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

fhir, fhir_at_rest, freezed_annotation, http, json_annotation

More

Packages that depend on fhir_uscore