flexilayout 0.3.0 copy "flexilayout: ^0.3.0" to clipboard
flexilayout: ^0.3.0 copied to clipboard

A flexible layout framework for Flutter applications, suitable for web and desktop.

0
likes
40/ 140
pub points
3%
popularity

We analyzed this package 7 days ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.cn/go/sdk-version-pinning for details.
failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: flutter pub get failed:
OUT:
Resolving dependencies...
ERR:
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.cn/go/sdk-version-pinning for details.


Because flexilayout depends on flutter_localizations from sdk which depends on intl 0.19.0, intl 0.19.0 is required.
So, because flexilayout depends on intl ^0.18.0, version solving failed.


You can try the following suggestion to make the pubspec resolve:
* Try upgrading your constraint on intl: flutter pub add intl:^0.19.0

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

0
likes
40
pub points
3%
popularity

Publisher

verified publisherdimlylit.dev

A flexible layout framework for Flutter applications, suitable for web and desktop.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

bloc, equatable, flutter, flutter_bloc, flutter_localizations, intl, uuid

More

Packages that depend on flexilayout