geolocator 11.0.0 copy "geolocator: ^11.0.0" to clipboard
geolocator: ^11.0.0 copied to clipboard

Geolocation plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API for generic location (GPS etc.) functions.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add geolocator

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  geolocator: ^11.0.0

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:geolocator/geolocator.dart';
5100
likes
140
pub points
100%
popularity

Publisher

verified publisherbaseflow.com

Geolocation plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API for generic location (GPS etc.) functions.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, geolocator_android, geolocator_apple, geolocator_platform_interface, geolocator_web, geolocator_windows

More

Packages that depend on geolocator