grpc_alice 0.0.3 copy "grpc_alice: ^0.0.3" to clipboard
grpc_alice: ^0.0.3 copied to clipboard

This package help to log GRPC request and response.

1
likes
80/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://ametory.id was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 20 API elements (5.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: grpc_alice, grpc_alice.ConsoleOutput, grpc_alice.ConsoleOutput.ConsoleOutput, grpc_alice.ConsoleOutput.destroy, grpc_alice.ConsoleOutput.init.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:grpc_alice/grpc_alice.dart that imports:
  • package:grpc_alice/src/interceptor.dart that imports:
  • package:grpc_alice/src/db_log_helper.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:grpc_alice/grpc_alice.dart that imports:
  • package:grpc_alice/src/interceptor.dart that imports:
  • package:grpc_alice/src/db_log_helper.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:grpc_alice/grpc_alice.dart that imports:
  • package:grpc_alice/src/widget.dart that imports:
  • package:shake/shake.dart that imports:
  • package:sensors_plus/sensors_plus.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Web`.

Because:

  • package:grpc_alice/grpc_alice.dart that imports:
  • package:grpc_alice/src/interceptor.dart that imports:
  • package:grpc_alice/src/db_log_helper.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: Unused import: 'dart:io'.

lib/src/db_log_helper.dart:4:8

  ╷
4 │ import 'dart:io' as io;
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/db_log_helper.dart

WARNING: This 'onError' handler must return a value assignable to 'R', but ends without returning a value.

lib/src/interceptor.dart:44:30

   ╷
44 │       ..catchError((e) async {
   │                              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/interceptor.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
grpc ^3.2.3 3.2.4 3.2.4
intl ^0.18.1 0.18.1 0.19.0
logger ^2.0.1 2.3.0 2.3.0
path ^1.8.3 1.9.0 1.9.0
path_provider ^2.0.15 2.1.3 2.1.3
provider ^6.0.5 6.1.2 6.1.2
shake ^2.2.0 2.2.0 2.2.0
sqflite ^2.3.0 2.3.3+1 2.3.3+1
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.0 3.6.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
google_identity_services_web - 0.3.1+1 0.3.1+1
googleapis_auth - 1.6.0 1.6.0
http - 1.2.1 1.2.1
http2 - 2.3.0 2.3.0
http_parser - 4.0.2 4.0.2
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
protobuf - 3.1.0 3.1.0
sensors_plus - 1.4.1 5.0.1
sensors_plus_platform_interface - 1.2.0 1.2.0
sensors_plus_web - 1.1.2 1.1.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sqflite_common - 2.5.4 2.5.4
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

1
likes
80
pub points
0%
popularity

Publisher

verified publisherametory.id

This package help to log GRPC request and response.

Homepage
Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, grpc, intl, logger, path, path_provider, provider, shake, sqflite

More

Packages that depend on grpc_alice