i18n_extension 12.0.1 copy "i18n_extension: ^12.0.1" to clipboard
i18n_extension: ^12.0.1 copied to clipboard

Translation and Internationalization (i18n) for Flutter. Easy to use for both large and small projects. Uses Dart extensions to reduce boilerplate.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add i18n_extension

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  i18n_extension: ^12.0.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:i18n_extension/i18n_extension.dart';
344
likes
140
pub points
96%
popularity

Publisher

verified publisherglasberg.dev

Translation and Internationalization (i18n) for Flutter. Easy to use for both large and small projects. Uses Dart extensions to reduce boilerplate.

Repository (GitHub)
View/report issues

Topics

#internationalization #localization #translation #i18n #extension

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, i18n_extension_core, intl

More

Packages that depend on i18n_extension