image_picker 1.1.1 copy "image_picker: ^1.1.1" to clipboard
image_picker: ^1.1.1 copied to clipboard

Flutter plugin for selecting images from the Android and iOS image library, and taking new pictures with the camera.

6637
likes
140/ 140
pub points
100%
popularity

We analyzed this package 27 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+image_picker%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected licenses: Apache-2.0, BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

50 out of 51 API elements (98.0 %) have documentation comments.

Some symbols that are missing documentation: image_picker.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
image_picker_android ^0.8.7 0.8.12+2 0.8.12+2
image_picker_for_web >=2.2.0 <4.0.0 3.0.4 3.0.4
image_picker_ios ^0.8.8 0.8.11+2 0.8.11+2
image_picker_linux ^0.2.1 0.2.1+1 0.2.1+1
image_picker_macos ^0.2.1 0.2.1+1 0.2.1+1
image_picker_platform_interface ^2.10.0 2.10.0 2.10.0
image_picker_windows ^0.2.1 0.2.1+1 0.2.1+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
cross_file - 0.3.4+1 0.3.4+1
file_selector_linux - 0.9.2+1 0.9.2+1
file_selector_macos - 0.9.4 0.9.4
file_selector_platform_interface - 2.6.2 2.6.2
file_selector_windows - 0.9.3+1 0.9.3+1
flutter_plugin_android_lifecycle - 2.0.20 2.0.20
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.1, Dart 3.4.1.

Check the analysis log for details.