l2cap_ble 0.0.1 copy "l2cap_ble: ^0.0.1" to clipboard
l2cap_ble: ^0.0.1 copied to clipboard

A flutter plugin to communicate with Bluetooth Low Energy devices using the L2CAP protocol.

3
likes
110/ 140
pub points
47%
popularity

We analyzed this package 5 days ago, and awarded it 110 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://github.com/appsfactorygmbh/flutter-l2cap was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 28 API elements (17.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: l2cap_ble, l2cap_ble.L2CapConnectionState, l2cap_ble.L2CapConnectionState.L2CapConnectionState, l2cap_ble.L2capBle, l2cap_ble.L2capBle.L2capBle.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:l2cap_ble/l2cap_ble.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:l2cap_ble/l2cap_ble.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:l2cap_ble/l2cap_ble.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:l2cap_ble/l2cap_ble.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/l2cap_ble.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/l2cap_ble_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

3
likes
110
pub points
47%
popularity

Publisher

verified publisherappsfactory.de

A flutter plugin to communicate with Bluetooth Low Energy devices using the L2CAP protocol.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#bluetooth

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on l2cap_ble