lints 2.0.0 copy "lints: ^2.0.0" to clipboard
lints: ^2.0.0 copied to clipboard

outdated

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

2.0.0 #

  • Added the following lints to core.yaml:
    • depend_on_referenced_packages
    • null_check_on_nullable_type_parameter
  • Added the following lints to recommended.yaml:
    • library_private_types_in_public_api
    • no_leading_underscores_for_library_prefixes
    • no_leading_underscores_for_local_identifiers
    • prefer_interpolation_to_compose_strings
    • unnecessary_constructor_name
    • unnecessary_late
    • unnecessary_null_aware_assignments
    • unnecessary_nullable_for_final_variable_declarations
  • Bumped the minimum required Dart SDK version to 2.17

1.0.1 #

  • Documentation updates

1.0.0 #

  • Initial stable version
225
likes
0
pub points
98%
popularity

Publisher

verified publishertools.dart.dev

Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart team.

Repository (GitHub)
View/report issues

License

unknown (LICENSE)

More

Packages that depend on lints