linux_serial 0.2.3+6 copy "linux_serial: ^0.2.3+6" to clipboard
linux_serial: ^0.2.3+6 copied to clipboard

Dart package for accessing serial ports on Linux using dart:ffi.

6
likes
130/ 140
pub points
47%
popularity

We analyzed this package 31 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 61 API elements (34.4 %) have documentation comments.

Some symbols that are missing documentation: linux_serial, linux_serial.Baudrate, linux_serial.Baudrate.asLinuxValue, linux_serial.Baudrate.b0, linux_serial.Baudrate.b50.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:linux_serial/linux_serial.dart that imports:
  • package:linux_serial/src/linux_serial.dart that imports:
  • package:_ardera_common_libc_bindings/_ardera_common_libc_bindings.dart that imports:
  • package:_ardera_common_libc_bindings/src/libc.dart that imports:
  • package:_ardera_common_libc_bindings/src/libc_functions.dart that imports:
  • package:_ardera_common_libc_bindings/src/libc_structs.dart that imports:
  • package:_ardera_common_libc_bindings/src/libc_arm.g.dart that imports:
  • package:_ardera_common_libc_bindings/src/ssize_t.dart that imports:
  • dart:ffi
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/linux_serial.dart:109:43

    ╷
109 │         final epollEvent = epollEventsPtr.elementAt(i);
    │                                           ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/linux_serial.dart

lib/linux_serial.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
_ardera_common_libc_bindings ^0.3.2 0.3.2+1 0.3.2+1
async ^2.5.0 2.11.0 2.11.0
collection ^1.18.0 1.18.0 1.18.0
computer ^3.2.1 3.2.1 3.2.1
ffi ^2.0.0 2.1.2 2.1.2
meta ^1.3.0 1.15.0 1.15.0
path ^1.8.0 1.9.0 1.9.0
synchronized ^3.0.0 3.1.0+1 3.1.0+1
tuple ^2.0.0 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 68.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.5.0
args - 2.5.0 2.5.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
build_config - 1.1.1 1.1.1
build_daemon - 4.0.2 4.0.2
build_resolvers - 2.4.2 2.4.2
build_runner - 2.4.10 2.4.10
build_runner_core - 7.3.0 7.3.0
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
checked_yaml - 2.0.3 2.0.3
code_builder - 4.10.0 4.10.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
graphs - 2.3.1 2.3.1
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
macros - 0.1.0-main.0 0.1.0-main.6
matcher - 0.12.16+1 0.12.16+1
mime - 1.0.5 1.0.5
package_config - 2.1.0 2.1.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.2.3 1.2.3
quiver - 3.2.1 3.2.1
shelf - 1.4.1 1.4.1
shelf_web_socket - 2.0.0 2.0.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1
timing - 1.0.1 1.0.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket - 0.1.4 0.1.4
web_socket_channel - 3.0.0 3.0.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.