motion_web 2.0.0 copy "motion_web: ^2.0.0" to clipboard
motion_web: ^2.0.0 copied to clipboard

Platformweb

The web implementation for the Motion plugin.

0
likes
105/ 140
pub points
37%
popularity

We analyzed this package 2 days ago, and awarded it 105 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/mrcendre/motion/issues?q=is%3Aissue+is%3Aopen was unreachable. Make sure that the website is reachable via HEAD requests.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:7:36

  ╷
7 │ <p>In other words, by depending on <a href="httpd://pub-web.flutter-io.cn/packages/motion"><code>motion</code></a>, the web version of your app
  │                                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 16 API elements (56.3 %) have documentation comments.

Some symbols that are missing documentation: motion_web, motion_web.WebMotion.initialize, motion_web.WebMotion.lastDeviceMotionEvent, motion_web.WebMotion.onDeviceMotion, motion_web.WebMotion.requestPermission.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:motion_web/motion_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:motion_web/motion_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:motion_web/motion_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:motion_web/motion_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:motion_web/motion_web.dart that declares support for platforms: Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:motion_web/motion_web.dart that imports:
  • package:motion_web/src/motion.dart that imports:
  • package:motion_platform_interface/motion_platform_interface.dart that imports:
  • package:motion_platform_interface/src/native_motion.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Uses 'await' on an instance of 'bool', which is not a subtype of 'Future'.

lib/src/motion.dart:204:32

    ╷
204 │         _isPermissionGranted = await evaluatePermission as bool? ?? false;
    │                                ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/motion.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
motion_platform_interface ^2.0.0 2.0.0 2.0.0
web ^0.5.1 0.5.1 0.5.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.