openapi_freezed_dio_builder 0.9.4 copy "openapi_freezed_dio_builder: ^0.9.4" to clipboard
openapi_freezed_dio_builder: ^0.9.4 copied to clipboard

Generate models and API classes based on an OpenAPI document using Freezed and Dio.

25
likes
110/ 140
pub points
28%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 26 API elements (3.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: openapi_freezed_dio_builder, openapi_freezed_dio_builder.OpenApiCodeBuilderUtils, openapi_freezed_dio_builder.OpenApiCodeBuilderUtils.OpenApiCodeBuilderUtils, openapi_freezed_dio_builder.OpenApiCodeBuilderUtils.formatLibrary, openapi_freezed_dio_builder.OpenApiCodeBuilderUtils.loadApiFromYaml.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:openapi_freezed_dio_builder/openapi_freezed_dio_builder.dart that imports:
  • package:openapi_freezed_dio_builder/src/openapi_code_builder.dart that imports:
  • package:openapi_base/openapi_base.dart that imports:
  • package:openapi_base/src/server/openapi_shelf_noop_server.dart that imports:
  • package:openapi_base/src/server/openapi_server_base.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

WARNING: The value of the local variable 'url' isn't used.

lib/src/custom_allocator.dart:16:11

   ╷
16 │     final url = reference.url;
   │           ^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/custom_allocator.dart

WARNING: Unused import: 'dart:io'.

lib/src/openapi_code_builder.dart:3:8

  ╷
3 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/openapi_code_builder.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
build >=2.0.2 <3.0.0 2.4.1 2.4.1
built_collection ^5.1.1 5.1.1 5.1.1
code_builder >=4.0.0 <5.0.0 4.10.0 4.10.0
collection ^1.15.0 1.18.0 1.18.0
dart_style >=2.0.1 <3.0.0 2.3.6 2.3.6
json_annotation >=4.0.1 <6.0.0 4.8.1 4.8.1
logging ^1.0.1 1.2.0 1.2.0
meta >=1.5.0 <2.0.0 1.12.0 1.12.0
open_api_forked ^3.0.0+5 3.0.0+6 3.0.0+6
openapi_base ^1.0.2+2 1.3.1 1.3.1
path ^1.8.0 1.9.0 1.9.0
quiver ^3.0.1+1 3.2.1 3.2.1
recase ^4.0.0 4.1.0 4.1.0
source_gen >=1.0.2 <2.0.0 1.5.0 1.5.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
args - 2.4.2 2.4.2
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_value - 8.9.1 8.9.1
chunked_stream - 1.4.2 1.4.2
clock - 1.1.1 1.1.1
codable_forked - 1.0.0+3 1.0.0+3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dio - 5.4.1 5.4.1
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
logging_appenders - 1.2.0+1 1.2.0+1
matcher - 0.12.16+1 0.12.16+1
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
shelf - 1.4.1 1.4.1
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
uuid - 4.3.3 4.3.3
watcher - 1.1.0 1.1.0
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.