opus_dart 3.0.1 copy "opus_dart: ^3.0.1" to clipboard
opus_dart: ^3.0.1 copied to clipboard

Wraps libopus in dart, and additionally provides a dart friendly API for encoding and decoding

3
likes
140/ 140
pub points
77%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

228 out of 287 API elements (79.4 %) have documentation comments.

Some symbols that are missing documentation: opus_custom.FunctionsAndGlobals, opus_custom.FunctionsAndGlobals.FunctionsAndGlobals, opus_dart.OpusDecoder.decode, opus_dart.OpusDecoder.decodeFloat, opus_dart.OpusDestroyedError.OpusDestroyedError.decoder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.1.0 2.1.2 2.1.2
web_ffi ^0.7.1 0.7.2 0.7.2
Transitive dependencies
Package Constraint Compatible Latest
js - 0.6.7 0.7.1
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
140
pub points
77%
popularity

Publisher

verified publisherepnw.eu

Wraps libopus in dart, and additionally provides a dart friendly API for encoding and decoding

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

ffi, web_ffi

More

Packages that depend on opus_dart