pose 1.1.5 copy "pose: ^1.1.5" to clipboard
pose: ^1.1.5 copied to clipboard

Dart library for loading, viewing, augmenting, and handling .pose files

2
likes
120/ 140
pub points
0%
popularity

We analyzed this package 7 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: pose,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository URL mismatch: expected https://github.com/bipinkrish/pose but got https://github.com/bipinkrish/pose-dart.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

25 out of 50 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: numdart, numdart.ConstStructs.double_ushort, numdart.ConstStructs.float, numdart.ConstStructs.short, numdart.ConstStructs.triple_ushort.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:pose/pose.dart that imports:
  • package:pose/src/pose_visualizer.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/pose.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/pose_body.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
image ^4.1.7 4.1.7 4.1.7
tuple ^2.0.2 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.5.1 3.5.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
typed_data - 1.3.2 1.3.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

2
likes
120
pub points
0%
popularity

Publisher

verified publisherbipin.app

Dart library for loading, viewing, augmenting, and handling .pose files

Repository (GitHub)
View/report issues

Topics

#pose

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

image, tuple

More

Packages that depend on pose