skale 0.1.0 copy "skale: ^0.1.0" to clipboard
skale: ^0.1.0 copied to clipboard

SKALE.dart - A community built and maintained library for Dart & Flutter Projects building on SKALE Network

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 7 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-3.0.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 32 API elements (3.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: skale.AnonymousParams, skale.AnonymousParams.AnonymousParams, skale.AnonymousPow, skale.AnonymousPow.AnonymousPow, skale.BaseContract.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Dangling library doc comment.

lib/src/contract/base_contract.dart:1:1

  ╷
1 │ /// @license
  │ ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/contract/base_contract.dart

INFO: Dangling library doc comment.

lib/src/pow/anonymous.dart:1:1

  ╷
1 │ /// @license
  │ ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/pow/anonymous.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.1.1 3.1.1 3.1.1
eth_sig_util ^0.0.9 0.0.9 0.0.9
http ^0.13.6 0.13.6 1.2.1
web3dart ^2.6.1 2.6.1 2.7.3
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
buffer - 1.2.3 1.2.3
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
eip1559 - 0.6.1 0.6.2
eip55 - 1.0.2 1.0.2
equatable - 2.0.5 2.0.5
http_parser - 4.0.2 4.0.2
js - 0.7.1 0.7.1
json_rpc_2 - 3.0.2 3.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
sec - 1.1.0 1.1.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
wallet - 0.0.13 0.0.13

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.6` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

verified publisherdirtroad.dev

SKALE.dart - A community built and maintained library for Dart & Flutter Projects building on SKALE Network

Repository (GitHub)
View/report issues

Documentation

API reference

License

LGPL-3.0 (LICENSE)

Dependencies

convert, eth_sig_util, http, web3dart

More

Packages that depend on skale