use_template 1.0.2 copy "use_template: ^1.0.2" to clipboard
use_template: ^1.0.2 copied to clipboard

Allows you to use any Flutter & Dart project as a template with a single line command.

Use Template #

Allows you to use any Flutter & Dart project as a template with a single line command.
It basically clones/copies the project and than changes all imports and platform specific names.

Android iOS Linux macOS Windows Web

Installation #

Open terminal and type the following code.

> dart pub global activate use_template

Usage #

You are asked for three parameters.

  • New name:
    • This will be the new name of your application.
  • Template:
    • You can provide a git repository address containing the template project or a directory from your computer.
  • Directory to install template:
    • Provide a directory to install.

1. One line code usage #

With a template from a git repository
> use_template my_new_application https://github.com/baranacikgoz/BloC_repository_pattern_template C:\Users\baran\Software\
With a template from your computer
> use_template my_new_application C:\path_to_template\flutter_template_app C:\Users\baran\Software\

2. Interactive usage #

You can use interactive interface by passing no arguments.

> use_template

1

2

3

4

12
likes
150
pub points
0%
popularity

Publisher

verified publisherbaranacikgoz.dev

Allows you to use any Flutter & Dart project as a template with a single line command.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dcli

More

Packages that depend on use_template