use_template 1.0.2 copy "use_template: ^1.0.2" to clipboard
use_template: ^1.0.2 copied to clipboard

Allows you to use any Flutter & Dart project as a template with a single line command.

12
likes
150/ 160
pub points
0%
popularity

We analyzed this package 16 hours ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/baranacikgoz/use_template/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 24 API elements (95.8 %) have documentation comments.

Some symbols that are missing documentation: use_template.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:use_template/use_template.dart that imports:
  • package:use_template/src/name_changer_methods/change_windows_name.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:use_template/use_template.dart that imports:
  • package:use_template/src/name_changer_methods/change_windows_name.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Linux`.

Because:

  • package:use_template/use_template.dart that imports:
  • package:use_template/src/name_changer_methods/change_windows_name.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:use_template/use_template.dart that imports:
  • package:use_template/src/name_changer_methods/change_windows_name.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:use_template/use_template.dart that imports:
  • package:use_template/src/name_changer_methods/change_windows_name.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dcli ^1.31.1 1.36.2 4.0.1
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.1 3.6.1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
basic_utils - 3.9.4 5.7.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
chunked_stream - 1.4.2 1.4.2
circular_buffer - 0.11.0 0.11.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csv - 5.1.1 6.0.0
dart_console2 - 2.0.1 3.1.1
dcli_core - 1.36.2 4.0.0
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 6.1.4 7.0.0
file_utils - 1.0.1 1.0.1
functional_data - 1.2.0 1.2.0
glob - 2.1.2 2.1.2
globbing - 1.0.0 1.0.0
http - 0.13.6 1.2.1
http_parser - 4.0.2 4.0.2
ini - 2.1.0 2.1.0
intl - 0.17.0 0.19.0
js - 0.7.1 0.7.1
json2yaml - 3.0.1 3.0.1
json_annotation - 4.9.0 4.9.0
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mime - 1.0.5 1.0.5
path - 1.9.0 1.9.0
pointycastle - 3.9.1 3.9.1
posix - 4.1.0 6.0.1
pub_semver - 2.1.4 2.1.4
pubspec2 - 2.4.2 4.0.0
pubspec_lock - 3.0.2 3.0.2
quiver - 3.2.1 3.2.1
random_string - 2.3.1 2.3.1
scope - 3.0.0 4.1.0
settings_yaml - 4.0.1 8.1.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stacktrace_impl - 2.3.0 2.3.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sum_types - 0.3.5 0.3.5
system_info2 - 2.0.4 4.0.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
validators2 - 3.0.0 5.0.0
vin_decoder - 0.2.1-nullsafety 0.2.1-nullsafety
win32 - 3.1.4 5.5.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.31.1` on dcli does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

12
likes
150
pub points
0%
popularity

Publisher

verified publisherbaranacikgoz.dev

Allows you to use any Flutter & Dart project as a template with a single line command.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dcli

More

Packages that depend on use_template