about 2.1.3 copy "about: ^2.1.3" to clipboard
about: ^2.1.3 copied to clipboard

Displays an About dialog, which describes the application, can show licenses, changelog, and other information.

90
likes
140/ 140
pub points
90%
popularity

We analyzed this package 27 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

137 out of 149 API elements (91.9 %) have documentation comments.

Some symbols that are missing documentation: about, about.AboutContentState, about.AboutContentState.AboutContentState, about.AboutPageListTile.trailing, about.LicenseListPageState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_markdown ^0.6.0 0.6.23 0.6.23
markdown >=4.0.0 <8.0.0 7.2.2 7.2.2
path ^1.8.0 1.9.0 1.9.0
simple_mustache ^2.1.0 2.1.0 2.1.0
url_launcher >=6.0.0 <7.0.0 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

90
likes
140
pub points
90%
popularity

Publisher

verified publishernfet.net

Displays an About dialog, which describes the application, can show licenses, changelog, and other information.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, flutter_markdown, markdown, path, simple_mustache, url_launcher

More

Packages that depend on about