audioplayers_linux 3.1.0 copy "audioplayers_linux: ^3.1.0" to clipboard
audioplayers_linux: ^3.1.0 copied to clipboard

PlatformLinux

Linux implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

5
likes
130/ 140
pub points
91%
popularity

We analyzed this package 37 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

0 out of 0 API elements (100.0 %) have documentation comments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • audioplayers_linux that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • audioplayers_linux that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • audioplayers_linux that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • audioplayers_linux that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • audioplayers_linux that declares support for platforms: Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audioplayers_platform_interface ^6.1.0 6.1.0 6.1.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

5
likes
130
pub points
91%
popularity

Publisher

verified publisherblue-fire.xyz

Linux implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers_platform_interface, flutter

More

Packages that depend on audioplayers_linux