audioplayers_linux 4.0.0 copy "audioplayers_linux: ^4.0.0" to clipboard
audioplayers_linux: ^4.0.0 copied to clipboard

PlatformLinux

Linux implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

AudioPlayers


audioplayers_linux #

The Linux implementation of audioplayers.

Usage #

This package is endorsed, which means you can simply use audioplayers normally. This package will be automatically included in your app when you do, so you do not need to add it to your pubspec.yaml.

Setup for Linux #

Note: If Flutter was installed via Snap, you might encounter build errors due to dependency mismatching (like glibc). Check out how to install the Flutter SDK manually or build your application on a former Ubuntu release, e.g. ubuntu:20.04 via lxd.

Debian #

Dev Dependencies

Flutter dependencies:

sudo apt-get install clang cmake ninja-build pkg-config libgtk-3-dev liblzma-dev

GStreamer:

sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev

App Dependencies

Optional GStreamer Plugins (e.g. for .m3u8):

sudo apt-get install gstreamer1.0-plugins-good gstreamer1.0-plugins-bad

ArchLinux #

For Arch, simply install gstreamer and its plugins via pacman:

sudo pacman -S gstreamer gst-libav gst-plugins-base gst-plugins-good

You can install additional plugins as needed following the Wiki.

6
likes
130
pub points
90%
popularity

Publisher

verified publisherblue-fire.xyz

Linux implementation of audioplayers, a Flutter plugin to play multiple audio files simultaneously

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

audioplayers_platform_interface, flutter

More

Packages that depend on audioplayers_linux