drm_video 0.0.1 copy "drm_video: ^0.0.1" to clipboard
drm_video: ^0.0.1 copied to clipboard

Flutter Plugin to Play DRM Content - with every functionality provided by video_player

16
likes
40/ 140
pub points
28%
popularity

We analyzed this package 5 days ago, and awarded it 40 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/ponnamkarthik/drm_video/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.3. Cannot run `flutter pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.3.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.3)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

16
likes
40
pub points
28%
popularity

Publisher

verified publisherkarthikponnam.dev

Flutter Plugin to Play DRM Content - with every functionality provided by video_player

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on drm_video