ext_video_player 0.1.2 copy "ext_video_player: ^0.1.2" to clipboard
ext_video_player: ^0.1.2 copied to clipboard

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

87
likes
100/ 140
pub points
85%
popularity

We analyzed this package 1 hour ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

86 out of 88 API elements (97.7 %) have documentation comments.

Some symbols that are missing documentation: ext_video_player, ext_video_player.VideoPlayerController.youtubeVideoQuality.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:ext_video_player/ext_video_player.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:ext_video_player/ext_video_player.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

WARNING: Unused import: 'dart:convert'.

lib/ext_video_player.dart:6:8

  ╷
6 │ import 'dart:convert';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ext_video_player.dart

WARNING: Unused import: 'package:http/http.dart'.

lib/ext_video_player.dart:9:8

  ╷
9 │ import 'package:http/http.dart' as http;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ext_video_player.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.4 0.13.6 1.2.1
meta ^1.0.5 1.11.0 1.12.0
video_player_platform_interface ^4.1.0 4.2.0 6.2.2
video_player_web ^2.0.2 2.0.15 2.2.0
youtube_explode_dart ^1.10.10 1.12.4 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
fake_async - 1.3.1 1.3.1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
freezed_annotation - 2.4.1 2.4.1
html - 0.15.4 0.15.4
http_parser - 4.0.2 4.0.2
json_annotation - 4.8.1 4.8.1
leak_tracker - 10.0.3 10.0.4
leak_tracker_flutter_testing - 3.0.2 3.0.3
leak_tracker_testing - 3.0.0 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.0.0 14.0.0
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.13.4` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^4.1.0` on video_player_platform_interface does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions video_player_platform_interface to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Flutter 3.20.0-1.1.pre, Dart 3.4.0-99.0.dev.

Check the analysis log for details.

87
likes
100
pub points
85%
popularity

Publisher

verified publisherkarthikponnam.dev

Flutter plugin for displaying inline with other Flutter widgets on Android and iOS. This plugin also supports playing youtube videos & RTMP Streams

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, http, meta, video_player_platform_interface, video_player_web, youtube_explode_dart

More

Packages that depend on ext_video_player