file_picker 6.1.1 copy "file_picker: ^6.1.1" to clipboard
file_picker: ^6.1.1 copied to clipboard

A package that allows you to use a native file explorer to pick single or multiple absolute file paths, with extension filtering support.

3901
likes
120/ 140
pub points
100%
popularity

We analyzed this package 4 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

21 out of 38 API elements (55.3 %) have documentation comments.

Some symbols that are missing documentation: file_picker, file_picker.FilePicker.platform, file_picker.FilePickerResult, file_picker.FilePickerResult.FilePickerResult, file_picker.FilePickerStatus.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/windows/file_picker_windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:file_picker/file_picker.dart that imports:
  • package:file_picker/src/file_picker.dart that imports:
  • package:file_picker/src/linux/file_picker_linux.dart that imports:
  • package:file_picker/src/utils.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/windows/file_picker_windows.dart:265:59

    ╷
265 │       final char = openFileNameW.lpstrFile.cast<Uint16>().elementAt(i).value;
    │                                                           ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/windows/file_picker_windows.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.9 2.0.17 2.0.17
flutter_web_plugins flutter 0.0.0 0.0.0
path ^1.8.2 1.9.0 1.9.0
plugin_platform_interface ^2.1.4 2.1.8 2.1.8
win32 ^5.0.2 5.2.0 5.2.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

3901
likes
120
pub points
100%
popularity

Publisher

verified publishermiguelruivo.com

A package that allows you to use a native file explorer to pick single or multiple absolute file paths, with extension filtering support.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter, flutter_plugin_android_lifecycle, flutter_web_plugins, path, plugin_platform_interface, win32

More

Packages that depend on file_picker