firebase_core_web 2.17.0 copy "firebase_core_web: ^2.17.0" to clipboard
firebase_core_web: ^2.17.0 copied to clipboard

Platformweb

The web implementation of firebase_core

49
likes
110/ 140
pub points
99%
popularity

We analyzed this package 12 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

37 out of 84 API elements (44.0 %) have documentation comments.

Some symbols that are missing documentation: firebase_core_web, firebase_core_web.EnsurePluginInitialized, firebase_core_web_interop, firebase_core_web_interop.AppJsImpl, firebase_core_web_interop.AppJsImpl.AppJsImpl.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Web

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web.
Package does not support platform `iOS`.

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web.
Package does not support platform `Windows`.

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web.
Package does not support platform `Linux`.

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web.
Package does not support platform `macOS`.

Because:

  • package:firebase_core_web/firebase_core_web.dart that declares support for platforms: Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:firebase_core_web/firebase_core_web.dart that imports:
  • package:firebase_core_web/src/interop/core.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/firebase_app_web.dart:6:1

  ╷
6 │ part of firebase_core_web;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firebase_app_web.dart

INFO: The part-of directive uses a library name.

lib/src/firebase_core_web.dart:6:1

  ╷
6 │ part of firebase_core_web;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firebase_core_web.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_core_platform_interface ^5.0.0 5.0.0 5.0.0
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
meta ^1.8.0 1.12.0 1.15.0
web ^0.5.1 0.5.1 0.5.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
flutter_test - 0.0.0 0.0.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.