firebase_crashlytics 3.4.16 copy "firebase_crashlytics: ^3.4.16" to clipboard
firebase_crashlytics: ^3.4.16 copied to clipboard

Flutter plugin for Firebase Crashlytics. It reports uncaught errors to the Firebase console.

1053
likes
130/ 140
pub points
100%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

17 out of 18 API elements (94.4 %) have documentation comments.

Some symbols that are missing documentation: firebase_crashlytics.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Web`.

Because:

  • package:firebase_crashlytics/firebase_crashlytics.dart that declares support for platforms: Android, iOS, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The part-of directive uses a library name.

lib/src/firebase_crashlytics.dart:6:1

  ╷
6 │ part of firebase_crashlytics;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/firebase_crashlytics.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
firebase_core ^2.25.5 2.25.5 2.25.5
firebase_core_platform_interface ^5.0.0 5.0.0 5.0.0
firebase_crashlytics_platform_interface ^3.6.23 3.6.23 3.6.23
flutter flutter 0.0.0 0.0.0
stack_trace ^1.10.0 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.23 1.3.23
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core_web - 2.11.5 2.11.5
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.1.0
web - 0.4.2 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.