flutter_aliplayer 6.7.0 copy "flutter_aliplayer: ^6.7.0" to clipboard
flutter_aliplayer: ^6.7.0 copied to clipboard

Aliyun Player With Flutter

18
likes
95/ 140
pub points
84%
popularity

We analyzed this package 5 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

216 out of 441 API elements (49.0 %) have documentation comments.

Some symbols that are missing documentation: flutter_alidownloader, flutter_alidownloader.FlutterAliDownloader, flutter_alidownloader.FlutterAliDownloader.getFullSaveForIOS, flutter_alidownloader.FlutterAliDownloader.FlutterAliDownloader.init, flutter_alilistplayer.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutter_aliplayer/flutter_aliplayer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutter_aliplayer/flutter_aliplayer.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:flutter_aliplayer/flutter_aliplayer.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutter_aliplayer/flutter_aliplayer.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: AliPlayerView.aliPlayerViewType

lib/flutter_aliplayer.dart:1260:7

     ╷
1260 │ class AliPlayerView extends StatefulWidget {
     │       ^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_aliplayer.dart

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/flutter_aliplayer.dart:1298:48

     ╷
1298 │           "viewType": widget.aliPlayerViewType.name,
     │                                                ^^^^
     ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/flutter_aliplayer.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

18
likes
95
pub points
84%
popularity

Publisher

unverified uploader

Aliyun Player With Flutter

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on flutter_aliplayer