flutterfire_ui 0.4.3+20 copy "flutterfire_ui: ^0.4.3+20" to clipboard
flutterfire_ui: ^0.4.3+20 copied to clipboard

discontinued
PlatformAndroidiOS

UI library built on top of firebase services

422
likes
90/ 140
pub points
95%
popularity

We analyzed this package 9 hours ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/firebase/flutterfire/tree/master/packages/flutterfire_ui was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/firebase/flutterfire/tree/master/packages/flutterfire_ui was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: flutterfire_ui,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: flutterfire_ui.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

169 out of 1050 API elements (16.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: auth, auth.AppleProviderButtonStyle, auth.AppleProviderButtonStyle.AppleProviderButtonStyle, auth.AppleProviderButtonStyle.backgroundColor, auth.AppleProviderButtonStyle.borderColor.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/email_link_provider_configuration.dart that imports:
  • package:firebase_dynamic_links/firebase_dynamic_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:firebase_core/firebase_core.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.
Package does not support platform `macOS`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/email_link_provider_configuration.dart that imports:
  • package:firebase_dynamic_links/firebase_dynamic_links.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:flutterfire_ui/auth.dart that imports:
  • package:flutterfire_ui/src/auth/configs/email_link_provider_configuration.dart that imports:
  • package:firebase_dynamic_links/firebase_dynamic_links.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

WARNING: Duplicate export.

lib/auth.dart:44:8

   ╷
44 │ export 'src/auth/widgets/auth_flow_builder.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/auth.dart

INFO: 'fetchSignInMethodsForEmail' is deprecated and shouldn't be used. fetchSignInMethodsForEmail() has been deprecated. Migrating off of this method is recommended as a security best-practice. Learn more in the Identity Platform documentation: https://cloud.google.com/identity-platform/docs/admin/email-enumeration-protection.

lib/src/auth/auth_flow.dart:98:34

   ╷
98 │       final methods = await auth.fetchSignInMethodsForEmail(email);
   │                                  ^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/auth/auth_flow.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cloud_firestore ^4.0.5 4.17.0 4.17.0
collection ^1.15.0 1.18.0 1.18.0
crypto ^3.0.1 3.0.3 3.0.3
desktop_webview_auth ^0.0.5 0.0.15 0.0.15
email_validator ^2.0.1 2.1.17 2.1.17
firebase_auth ^4.1.2 4.19.1 4.19.1
firebase_core ^2.2.0 2.30.0 2.30.0
firebase_database ^10.0.1 10.5.2 10.5.2
firebase_dynamic_links ^5.0.5 5.5.2 5.5.2
flutter flutter 0.0.0 0.0.0
flutter_facebook_auth ^4.0.1 4.4.1+1 6.2.0
flutter_localizations flutter 0.0.0 0.0.0
flutter_svg ^1.0.0 1.1.6 2.0.10+1
google_sign_in ^5.2.1 5.4.4 6.2.1
sign_in_with_apple ^3.3.0 3.3.0 6.1.0
twitter_login ^4.2.2 4.4.2 4.4.2
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.30 1.3.30
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 6.2.0 6.2.0
cloud_firestore_web - 3.12.0 3.12.0
fake_async - 1.3.1 1.3.1
firebase_auth_platform_interface - 7.2.2 7.2.2
firebase_auth_web - 5.11.1 5.11.1
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.15.0 2.15.0
firebase_database_platform_interface - 0.2.5+30 0.2.5+30
firebase_database_web - 0.2.5+2 0.2.5+2
firebase_dynamic_links_platform_interface - 0.2.6+30 0.2.6+30
flutter_facebook_auth_platform_interface - 3.2.0 5.0.0
flutter_facebook_auth_web - 3.2.0 5.0.1
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
google_sign_in_android - 6.1.23 6.1.23
google_sign_in_ios - 5.7.5 5.7.5
google_sign_in_platform_interface - 2.4.5 2.4.5
google_sign_in_web - 0.10.2+1 0.12.4
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.18.1 0.19.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.0 10.0.5
leak_tracker_flutter_testing - 2.0.1 3.0.5
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_drawing - 1.0.1 1.0.1
path_parsing - 1.0.1 1.0.1
petitparser - 6.0.2 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
sign_in_with_apple_platform_interface - 1.1.0 1.1.0
sign_in_with_apple_web - 1.0.1 2.1.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.2.0
web - 0.5.1 0.5.1
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^4.0.1` on flutter_facebook_auth does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions flutter_facebook_auth to update the constraint.

The constraint `^1.0.0` on flutter_svg does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.