geoflutterfire2 2.3.15 copy "geoflutterfire2: ^2.3.15" to clipboard
geoflutterfire2: ^2.3.15 copied to clipboard

GeoFlutterFire2 is an open-source library that allows you to store and query firestore documents based on their geographic location.

107
likes
130/ 140
pub points
97%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

15 out of 33 API elements (45.5 %) have documentation comments.

Some symbols that are missing documentation: geoflutterfire2, geoflutterfire2.Coordinates, geoflutterfire2.Coordinates.Coordinates, geoflutterfire2.Coordinates.latitude, geoflutterfire2.Coordinates.longitude.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:geoflutterfire2/geoflutterfire2.dart that imports:
  • package:geoflutterfire2/src/point.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that declares support for platforms: Android, iOS, Windows, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:geoflutterfire2/geoflutterfire2.dart that imports:
  • package:geoflutterfire2/src/point.dart that imports:
  • package:cloud_firestore/cloud_firestore.dart that imports:
  • package:firebase_core_platform_interface/firebase_core_platform_interface.dart that imports:
  • package:firebase_core_platform_interface/src/pigeon/test_api.dart that imports:
  • package:flutter_test/flutter_test.dart that imports:
  • package:flutter_test/src/widget_tester.dart that imports:
  • package:flutter_test/src/test_text_input.dart that imports:
  • package:flutter_test/src/test_text_input_key_handler.dart that imports:
  • package:flutter_test/src/binding.dart that imports:
  • package:flutter_test/src/platform.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The file name 'DistanceDocSnapshot.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/DistanceDocSnapshot.dart

INFO: An uninitialized variable should have an explicit type annotation.

lib/src/util.dart:170:9

    ╷
170 │     var neighborLat, neighborLon;
    │         ^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/util.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cloud_firestore ^4.4.4 4.17.4 4.17.4
flutter flutter 0.0.0 0.0.0
rxdart ^0.27.7 0.27.7 0.27.7
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.3.34 1.3.34
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 6.2.4 6.2.4
cloud_firestore_web - 3.12.4 3.12.4
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
firebase_core - 2.31.1 2.31.1
firebase_core_platform_interface - 5.0.0 5.0.0
firebase_core_web - 2.17.0 2.17.0
flutter_test - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

107
likes
130
pub points
97%
popularity

Publisher

verified publisherbeerstorm.net

GeoFlutterFire2 is an open-source library that allows you to store and query firestore documents based on their geographic location.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter, rxdart

More

Packages that depend on geoflutterfire2