google_mobile_ads 4.0.0 copy "google_mobile_ads: ^4.0.0" to clipboard
google_mobile_ads: ^4.0.0 copied to clipboard

Flutter plugin for Google Mobile Ads, supporting banner, interstitial (full-screen), rewarded and native ads

2081
likes
125/ 140
pub points
99%
popularity

We analyzed this package 2 days ago, and awarded it 125 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:22:4

   ╷
22 │ <p><a href="http://www.apache.org/licenses/LICENSE-2.0.html">Apache 2.0 License</a></p>
   │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

354 out of 355 API elements (99.7 %) have documentation comments.

Some symbols that are missing documentation: google_mobile_ads.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that imports:
  • package:google_mobile_ads/src/mobile_ads.dart that imports:
  • package:google_mobile_ads/src/ad_instance_manager.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:google_mobile_ads/google_mobile_ads.dart that imports:
  • package:google_mobile_ads/src/mobile_ads.dart that imports:
  • package:google_mobile_ads/src/ad_instance_manager.dart that imports:
  • package:webview_flutter_android/webview_flutter_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: Missing a corresponding override of 'hashCode'.

lib/src/ad_containers.dart:237:17

    ╷
237 │   bool operator ==(Object other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/ad_containers.dart

INFO: Missing a corresponding override of 'hashCode'.

lib/src/ad_containers.dart:287:17

    ╷
287 │   bool operator ==(Object other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/ad_containers.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.0.4 1.11.0 1.12.0
webview_flutter ^4.0.5 4.7.0 4.7.0
webview_flutter_android ^3.3.1 3.15.0 3.15.0
webview_flutter_wkwebview ^3.1.1 3.12.0 3.12.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
webview_flutter_platform_interface - 2.10.0 2.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

2081
likes
125
pub points
99%
popularity

Publisher

verified publishergoogle.dev

Flutter plugin for Google Mobile Ads, supporting banner, interstitial (full-screen), rewarded and native ads

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, meta, webview_flutter, webview_flutter_android, webview_flutter_wkwebview

More

Packages that depend on google_mobile_ads