hive_ui 1.0.14 copy "hive_ui: ^1.0.14" to clipboard
hive_ui: ^1.0.14 copied to clipboard

DBMS Hive Ui is a package that presents a smart methodology to work with the Hive database, It is easy to view, edit and create new rows.

41
likes
110/ 140
pub points
81%
popularity

We analyzed this package 4 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

82 out of 236 API elements (34.7 %) have documentation comments.

Some symbols that are missing documentation: add_dialog, add_dialog.AddNewDialog, add_dialog.AddNewDialog.AddNewDialog, add_dialog.AddNewDialog.allColumns, add_dialog.AddNewDialog.objectAsJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:hive_ui/hive_ui.dart that imports:
  • package:hive_ui/boxes_view.dart that imports:
  • package:hive_ui/widgets/update_dialog.dart that imports:
  • package:hive_ui/widgets/update_dialog_type_picker.dart that imports:
  • package:hive_ui/core/screen_utils.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/search/drop_down_search/dropdown.dart:368:30

    ╷
368 │           Overlay.of(context)!
    │                              ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/search/drop_down_search/dropdown.dart

WARNING: The receiver can't be null, so the null-aware operator '?.' is unnecessary.

lib/search/drop_down_search/dropdown.dart:369:15

    ╷
369 │               ?.insertAll([_overlayBackdropEntry!, _overlayEntry!]);
    │               ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/search/drop_down_search/dropdown.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
hive_flutter ^1.1.0 1.1.0 1.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
hive - 2.2.3 2.2.3
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

41
likes
110
pub points
81%
popularity

Publisher

verified publisherappsgateway.website

DBMS Hive Ui is a package that presents a smart methodology to work with the Hive database, It is easy to view, edit and create new rows.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, hive_flutter

More

Packages that depend on hive_ui