json_intl 3.0.1 copy "json_intl: ^3.0.1" to clipboard
json_intl: ^3.0.1 copied to clipboard

Flutter Internationalization library based on Json files and mustache replacement strings.

8
likes
120/ 140
pub points
68%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

38 out of 61 API elements (62.3 %) have documentation comments.

Some symbols that are missing documentation: json_intl, json_intl.Translated, json_intl.Translated.Translated, json_intl.Translated.keyword, json_intl.Translated.map.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The argument type 'Locale' isn't related to 'String'.

lib/src/loaders.dart:65:24

   ╷
65 │   if (data.containsKey(locale)) {
   │                        ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/loaders.dart

INFO: The argument type 'Locale' isn't related to 'String'.

lib/src/loaders.dart:66:29

   ╷
66 │     into.appendBuiltin(data[locale]!);
   │                             ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/loaders.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl >=0.17.0 <0.19.0 0.18.1 0.19.0
logging ^1.1.0 1.2.0 1.2.0
meta >=1.3.0 <=2.0.0 1.11.0 1.14.0
path ^1.8.0 1.9.0 1.9.0
simple_mustache ^2.1.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.17.0 <0.19.0` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

8
likes
120
pub points
68%
popularity

Publisher

verified publishernfet.net

Flutter Internationalization library based on Json files and mustache replacement strings.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, intl, logging, meta, path, simple_mustache

More

Packages that depend on json_intl