json_serializable 6.7.1 copy "json_serializable: ^6.7.1" to clipboard
json_serializable: ^6.7.1 copied to clipboard

Automatically generate code for converting to and from JSON by annotating Dart classes.

3228
likes
140/ 140
pub points
99%
popularity

We analyzed this package 3 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

53 out of 121 API elements (43.8 %) have documentation comments.

Some symbols that are missing documentation: json_serializable, json_serializable.JsonEnumGenerator, json_serializable.JsonEnumGenerator.JsonEnumGenerator, json_serializable.JsonEnumGenerator.throwOnUnresolved, json_serializable.JsonEnumGenerator.typeChecker.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:json_serializable/json_serializable.dart that imports:
  • package:json_serializable/src/json_serializable_generator.dart that imports:
  • package:json_serializable/src/type_helpers/uri_helper.dart that imports:
  • package:json_serializable/src/type_helpers/to_from_string.dart that imports:
  • package:json_serializable/src/default_container.dart that imports:
  • package:json_serializable/src/utils.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:json_serializable/json_serializable.dart that imports:
  • package:json_serializable/src/json_serializable_generator.dart that imports:
  • package:json_serializable/src/type_helpers/uri_helper.dart that imports:
  • package:json_serializable/src/type_helpers/to_from_string.dart that imports:
  • package:json_serializable/src/default_container.dart that imports:
  • package:json_serializable/src/utils.dart that imports:
  • package:source_helper/source_helper.dart that imports:
  • package:source_helper/src/dart_type_extension.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:json_serializable/json_serializable.dart that imports:
  • package:json_serializable/src/json_serializable_generator.dart that imports:
  • package:json_serializable/src/type_helpers/uri_helper.dart that imports:
  • package:json_serializable/src/type_helpers/to_from_string.dart that imports:
  • package:json_serializable/src/default_container.dart that imports:
  • package:json_serializable/src/utils.dart that imports:
  • package:json_serializable/src/type_helpers/config_types.dart that imports:
  • package:analyzer/dart/constant/value.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/error/error_code_values.g.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/fasta/doc_comment_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/resolver.dart that imports:
  • package:analyzer/src/generated/static_type_analyzer.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inference_helper.dart that imports:
  • package:analyzer/src/dart/resolver/invocation_inferrer.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/resolver/flow_analysis_visitor.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/link.dart that imports:
  • package:analyzer/src/summary2/types_builder.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/util/uri.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/pub.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/blaze.dart that imports:
  • package:analyzer/src/workspace/blaze_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=5.12.0 <7.0.0 6.4.1 6.4.1
async ^2.8.0 2.11.0 2.11.0
build ^2.0.0 2.4.1 2.4.1
build_config >=0.4.4 <2.0.0 1.1.1 1.1.1
collection ^1.14.0 1.18.0 1.18.0
json_annotation >=4.8.1 <4.9.0 4.8.1 4.8.1
meta ^1.3.0 1.12.0 1.12.0
path ^1.8.0 1.9.0 1.9.0
pub_semver ^2.0.0 2.1.4 2.1.4
pubspec_parse ^1.0.0 1.2.3 1.2.3
source_gen ^1.3.2 1.5.0 1.5.0
source_helper ^1.3.0 1.3.4 1.3.4
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
args - 2.4.2 2.4.2
checked_yaml - 2.0.3 2.0.3
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.4 2.3.4
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
package_config - 2.1.0 2.1.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.