permission_handler 11.3.1 copy "permission_handler: ^11.3.1" to clipboard
permission_handler: ^11.3.1 copied to clipboard

Permission plugin for Flutter. This plugin provides a cross-platform (iOS, Android) API to request and check permissions.

4970
likes
140/ 140
pub points
100%
popularity

We analyzed this package 7 days ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/Baseflow/flutter-permission-handler/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

95 out of 96 API elements (99.0 %) have documentation comments.

Some symbols that are missing documentation: permission_handler.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.7.0 1.12.0 1.15.0
permission_handler_android ^12.0.3 12.0.6 12.0.6
permission_handler_apple ^9.4.3 9.4.4 9.4.4
permission_handler_html ^0.1.1 0.1.1 0.1.1
permission_handler_platform_interface ^4.2.0 4.2.1 4.2.1
permission_handler_windows ^0.2.1 0.2.1 0.2.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.