provider_for_redux 7.0.1 copy "provider_for_redux: ^7.0.1" to clipboard
provider_for_redux: ^7.0.1 copied to clipboard

Allows you to use Provider with Redux. Uses AsyncRedux, the non-boilerplate version of Redux (https://pub-web.flutter-io.cn/packages/async_redux).

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add provider_for_redux

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  provider_for_redux: ^7.0.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:provider_for_redux/provider_for_redux.dart';
16
likes
140
pub points
79%
popularity

Publisher

verified publisherglasberg.dev

Allows you to use Provider with Redux. Uses AsyncRedux, the non-boilerplate version of Redux (https://pub-web.flutter-io.cn/packages/async_redux).

Repository (GitHub)
View/report issues

Topics

#provider #redux #state-management

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

async_redux, flutter, path_provider, provider

More

Packages that depend on provider_for_redux