provider_for_redux 7.0.1 copy "provider_for_redux: ^7.0.1" to clipboard
provider_for_redux: ^7.0.1 copied to clipboard

Allows you to use Provider with Redux. Uses AsyncRedux, the non-boilerplate version of Redux (https://pub-web.flutter-io.cn/packages/async_redux).

16
likes
140/ 160
pub points
79%
popularity

We analyzed this package 23 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

12 out of 17 API elements (70.6 %) have documentation comments.

Some symbols that are missing documentation: provider_for_redux, provider_for_redux.AsyncReduxProvider.builder, provider_for_redux.AsyncReduxProvider.child, provider_for_redux.AsyncReduxProvider.dispose, provider_for_redux.AsyncReduxProvider.AsyncReduxProvider.value.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/provider_for_redux.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async_redux ^21.0.1 21.7.1 23.0.2
flutter flutter 0.0.0 0.0.0
path_provider ^2.1.1 2.1.3 2.1.3
provider ^6.1.1 6.1.2 6.1.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
fast_immutable_collections - 10.2.4 10.2.4
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.5 2.2.5
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
weak_map - 3.0.1 3.0.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^21.0.1` on async_redux does not support the stable version `22.0.0`.

Try running dart pub upgrade --major-versions async_redux to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

16
likes
140
pub points
79%
popularity

Publisher

verified publisherglasberg.dev

Allows you to use Provider with Redux. Uses AsyncRedux, the non-boilerplate version of Redux (https://pub-web.flutter-io.cn/packages/async_redux).

Repository (GitHub)
View/report issues

Topics

#provider #redux #state-management

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

async_redux, flutter, path_provider, provider

More

Packages that depend on provider_for_redux